PAX2 Vaporizer

Is this overfert / nutrient burn?

Discussion in 'Plant Problems' started by jelloscooter, Aug 13, 2007.

  1. jelloscooter

    jelloscooter Registered+

    About 3 weeks into flowering, and I've had a little PH lockout before, so I was wondering if the nutrients were accumulating in the soil and unleashed when the PH was brought back around... I've also been foliar feeding thinking that there was a micro deficiency.

    Could anyone verify if this is indeed overfert / nutrient burn?
     

    Attached Files:

  2. the image reaper

    the image reaper Registered+

  3. the image reaper

    the image reaper Registered+

  4. jelloscooter

    jelloscooter Registered+

    At first I was using 100% nute solution for foliar feeding, but for the past week or so i've been using a 50% solution. I was thinking that all of those nutrients sitting on the leaves may have contributed.

    I had nitrogen and phosphorous deficiencies earlier, as well as PH imbalance, and was trying to nurse it back- being a bad noobie I mixed my spray bottle with a regular strength solution.
     
  5. jelloscooter

    jelloscooter Registered+

    Would it be a good idea to let the plant rest for a couple waterings and feed it water with no nutrients?
     
  6. the image reaper

    the image reaper Registered+

    since you've been having some nutrient and pH issues, I believe I would let it sit with plain neutral pH waterings for a couple days ... also, when I foliar-feed, I re-spray the leaves the following day with plain water, to rinse off the nute buildup from feeding ... :smokin:
     
  7. jelloscooter

    jelloscooter Registered+

    Ah, thanks for the tips. I learn more every day ^_^
     
    Last edited: Aug 13, 2007

Share This Page